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4GETTING STARTED

1 — GETTING STARTED

   STARTING UBITY UC DESKPTOP

Install Ubity UC Desktop

Verify the status of your extension on the Ubity web interface in Management > Extensions > 
My extension. Next to your extension you will see the UC symbol.

If the UC is not activated on your extension, please contact the administrator of your account 
so that he can place an email request to our technical support at support@ubity.com to activate 
it.

Note : The activation of UC can generate additional monthly costs.

Download the appropriate setup executable file of Ubity UC Desktop for your computer via 
Install UC Software and follow the prompts in the install wizard.

Start Ubity UC Desktop

Start Ubity UC Desktop as you would any other program. The Ubity UC Desktop Login dialog 
appears.

Ubity UC Desktop icon

Download the executable 
Ubity UC Desktop installation 
file from here.

UC icon when it is activated, 
versus not activated :
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   IDENTIFY YOURSELF

Once the software is downloaded and installed, and you have started it by double-clicking the 
Ubity UC Desktop icon, you will be asked for a username and password. These credentials 
are the same as the ones you use on Ubity’s web management portal, commonly referred as 
Studio (https://studio.ubity.com).

Username : the username used to log into the Ubity management portal

Password : the password used to log into the Ubity management portal

If you don’t yet have a password, or can’t remember your password, you will have to request 
a new one by clicking on the “Recover your password” link on Studio’s login page (at the 
address above).

By checking the Remember password box, you will be automatically logged in each time you 
launch the software, without having to enter your username and password.
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    TEST YOUR EQUIPMENT

It is important to make a test call to ensure that your microphone, your headset and / or your 
camera work correctly. If this is not the case, you should contact an IT manager to help you set 
them (See “Testing Audio Devices”, “Testing Audio Quality” and “Testing Video Quality” on 
pages 46-48).

   MAKING A FIRST CALL

Try making calls with your new phone (page 10).

Having Troubles ?

Ubity UC Desktop includes tools for helping you troubleshoot problems. From the menu, 
choose Help > Troubleshooting.

• Audio tab: While you are on a phone call, you can test the quality of the audio. Note that to 
perform a valid test, you should be on an established call (not a call attempt).

• Video tab: You can verify that your camera is working.

• Devices tab: You can verify that your microphone and speakers are working and can set 
the volume to a comfortable level without having to actually place a phone call.

• Support tab: If none of the other tabs help you solve your problem, you can create logs of 
your activity and send them to customer support.
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   SETTING UP NOTIFICATIONS

Ubity UC Desktop uses OS notifications. Make sure that the notifications are set up for Ubity 
UC Desktop in system preferences.

From the menu, click Apple logo > System Preferences > Notifications. In the notification 
center, choose Ubity UC Desktop. Choose Banner or Alerts for the alert style. For details on 
incoming call notifications, see page 13.

   QUITTING UBITY UC DESKTOP

To quit Ubity UC Desktop, choose Ubity UC Desktop > Quit or press the Apple key + Q.

   CHECKING FOR UBITY UC DESKTOP UPDATES

If you are in an enterprise, your system administrator should tell you about the policy for 
checking for and installing upgrades.

To check for updates to Ubity UC Desktop, choose Help > Check for updates. The Auto 
Update window appears.

• If a new version of the software is available, you can download it from this window.

• If no newer version is available, this window informs you that your version is up to date.
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2 — MAKING PHONE CALLS

   THE ONSCREEN SOFTPHONE

Compact View

To create this compact view, go to Ubity UC Desktop, click View and hide all the resources 
tabs including the Dialpad.

      

Close window

Minimize to dock

Call entry field.  
See page 11.

Open the 
Messages window. 
See page 33

Voicemail 
indicator. See page 
28.

Resize softphone
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   THE UBITY UC DESKTOP MENU

The menu contains the following items that are specific to Ubity UC Desktop :

• Ubity UC Desktop > Preferences. See page 49.

Sign Out

To log off and minimize Ubity UC Desktop to the system tray. If you click the Ubity UC Desktop 
icon in the status bar, the Login screen appears. This menu item does not appear if you have 
configured Ubity UC Desktop for no login.

View

Changes how Ubity UC Desktop looks. Also lets you view the messages (see page 33).

Contacts

Lets you work with contacts.

Help

Provides access to various service-related features.
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   PLACING A CALL

Place the call as described in the table below. The outgoing call opens in its own call panel, 
below any other existing call panels. You will hear a ringing tone while Ubity UC Desktop 
attempts to make a connection.

Option From the... Description

Keying Dialpad or computer 
keyboard

1 Enter the number or address in the call entry 
field using the dialpad or the computer keyboard. 
To turn letters to numbers, see page 12.

As you type, a suggestion for completing the 
entry may appear. Choose the suggestion or keep 
typing.

2 Click the Call button or press Enter.

Control-click a 
contact

Contacts tab Control-click an entry from the Contacts tab and 
choose Call or Video Call.

(If the tab contains lots of entries, first search or 
filter the list.)

Double-click a 
contact

Contacts tab Contacts have a “double-click” action that either 
makes an audio phone call or starts an IM.

Single-click a 
contact

Contacts tab Hover over the right side of the contact to reveal 
the click-to-call button. Click to place a call using 
the primary phone number for this contact.

Redial Redial button • When the call entry field is empty, click the Call 
button.

• Or click the arrow in the call entry field and select 
a recent call.

An audio call is placed.

Dialing Dialpad 1 If the dialpad is not visible, click the Phone 
button at the bottom. 

2 Click the numbers on the dialpad to enter the 
phone number.

3 Click the Call button or press Enter.

From an instant 
message

Messages window Click the menu at the top of the Messages 
window and choose Call.
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Selecting the Account to Use

This information applies only if you have more than one SIP account set up and enabled.

When you place a call, you can explicitly specify the account to use for that call.

The account selection options appear only if you have two or more SIP accounts that are 
enabled and being used for phone calls. 

Call entry field
The Call icon. Clicking the down arrow gives you more 
call options, such as video call or conference call.

Auto complete suggestions. Ubity 
UC Desktop makes a call as soon 
as you choose the suggestion. You 
can change this behavior so Ubity 
UC Desktop does not dial until the 
Call button is pressed.

For information on working with the call, 
see “Handling an Established Call” on 
page 15.
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Letters to Numbers

You can type letters and Ubity UC Desktop will convert the letters to numbers when placing the 
call :

Placing another Call

You can place another call. There is no limit to the number of calls you can make, although 
eventually the quality of audio and video will degrade because of limitations on the computer.

Turn Letters-to-
numbers on or off.

Type the phone 
number using 
numbers and letters, 
as desired

When you click Call, the call panel 
will open and the call will be placed. 
The call panel will show the phone 
number all in digits.

Place the call in 
the usual way.

Existing call is 
automatically put on hold

New outgoing call
Switch between the different calls by 
clicking Resume on the desired call 
panel. That call becomes the active call 
and all other calls are on hold.
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   HANDLING INCOMING CALLS

Ubity UC Desktop must be running to answer incoming calls. (If Ubity UC Desktop is not 
running, incoming calls may be directed to voicemail ; check with your VoIP service provider or 
system administrator.)

When Ubity UC Desktop is in the foreground, the new call appears in its own call panel. 
When Ubity UC Desktop is in the background (the focus is on other application), the incoming 
call notification appears in the upper-right corner. To receive notifications, make sure that 
you configured both system preferences on Mac OS as well as Ubity UC Desktop’s alerts 
preferences (page 50).

When Ubity UC Desktop is in Foreground

When Ubity UC Desktop is in Background

The notifications do not indicate whether the incoming call is an audio or video call. If the 
incoming call is a video call, Ubity UC Desktop will answer with video.

Click the Call button. If you are 
on another call, that first call is 
automatically put on hold. You are 
now talking to the new caller. Or click Forward; a call entry field appears. Enter the 

name or number to forward to and click Forward Now.

Or click the End button. There will 
be a busy signal. The call may be 
directed to voicemail (if you have 
this service).

The Alert shows Answer and 
Decline buttons.
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Auto Answer

Auto answer is initially configured to auto-answer after one ring, and to send only your audio 
when the call is established. To change this configuration choose Preferences > Calls.

Auto answer is automatically turned off when you shut down or log off.

Disabling Call Waiting

You can turn on Disable Call Waiting. If on, when you are on a call, any new incoming call will 
go straight to voicemail or will ring as busy (to the caller). In this way, you are not distracted by 
incoming calls.

You can enable this feature even during a call, and it will take effect right away. The call will 
appear in the Missed Calls in the History tab.

Turn Auto Answer on or 
to set Ubity UC Desktop 
to automatically answer 
all incoming calls.

Auto Answer is initially configured to auto-
answer after one ring, and to send only your 
audio when the call is established. To change this 
configuration choose Preferences > Calls.

Auto Answer is automatically turned off when 
you shut down or log off.

Disable Call Waiting on or off.

A check mark indicates 
the feature is enabled (no 
interruption during a call).
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   HANDLING AN ESTABLISHED CALL

Ending a Call

Click the End call button on the Call panel (the call can be active or on hold). The Call panel 
closes after a few seconds.

Mute speaker or adjust speaker 
volume by using slider

Use speakerphone 
(when yellow), or 
headset (when gray)

Mute your voice

Hold and resume

Transfer. See page 16

Add video. See page 18

Place another call. The current call is 
automatically put on hold). See page 12

Add as Contact. If a plus symbol appears 
here, you can add the current caller as a 
contact. See “Updating Contacts from the 
Directory” on page 38.

Conference Calls (page 21)  
Instant Message. (page 30) 
Record the call (page 26)
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   TRANSFERING A CALL

Basic (Unattended) Transfer – Transfer this Call

        

Attended Transfer – Call then Transfer

You can first speak to the target (the person you are transferring the call to), then click Transfer 
Now to complete the transfer.

                    

Click the Transfer 
button.

The call is put on hold and 
a call entry field appears.

Type a name or number,  
or drag a contact into the field.

Then click 
Transfer Now.

The call may end immediately.

Or it may show “calling”, In this 
case, do not hang up immediately : 
if the other person does not answer, 
the call will come back to you.

Click the Transfer 
button.

The call is put on hold and 
a call entry field appears.

Type a name or number, 
or drag a contact into 
the field.

Then click the down arrow and 
choose Call First.

Or you can click the X to 
cancel the transfer request 
and return to the first call.
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Ubity UC Desktop 
phones the new 
person.

You can hang up the second call and 
return to the first call.

When the other person answers, the 
Transfer Now button is enabled.

When you are ready, click Transfer 
Now. The Call panel closes.

Or if the other person does not want to take 
the call, click X and return to the first call.
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   HANDLING VIDEO CALLS

Placing a Video Call

Calls made with Ubity UC Desktop will work without a video camera, but a video camera is 
necessary to allow other parties to see your image. Ubity UC Desktop will work with most USB 
video cameras.

From the Dashboard

Click the down arrow and choose Video 
Call. If you mostly make video calls, 
you can Option-click this down arrow 
to reveal the “Set Video Call as default 
action” menu item.
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From the Contact List or History

                    

Adding Video

If you have a camera, you can add video to a call that started as an audio call.

Click Start Video (  ) in the Call panel. When you add video, the other party may (or may 
not) start sending their video to you.

Other Party Adds Video

If the other party starts their video, your video window automatically opens and the video is 
played. You can start sending your own video, if desired (and assuming you have a camera) by 
clicking Start Video (  ) in the Call panel.

Ctrl-Click a contact and choose Video Call.



20MAKING PHONE CALLS

Pausing and Resuming Video

Click Stop Video in the call panel or close the video window to pause sending your video. Click 
Start Video to resume sending your video ; the video window will open.

Start or stop video.

Closing the video 
window stops sending 
video.

Mute

Display in full screen
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   CONFERENCE CALLS

Starting a Conference Call

You can start a conference call by :

• making a conference call from the dashboard,

• adding participants to an existing established call, or

• having two established calls and merging them to a conference call.

From the Dashboard

                    

Enter the number or address by 
typing.

Or select from the redial list, or 
drag a contact or history item.

Then choose Start 
Conference Call.

Type a name 
or number.

Click Add.

You can 
add more 
participants 
from here.
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From an Existing Call

From One Established Call 

From Two Established Calls

You can start the 
conference from here.

You can start a 
conference from here.
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Managing the Conference

Adding More Participants

You can add more participants to an existing conference in any of these ways :

• Ctrl-click on a contact and choose Add to Conference Call.

• In the conference call panel, click Invite to Conference Call, enter a name and then 
click Add.

• Add in a separate call that is not part of the conference call: In the call panel for the 
individual call, click the down arrow and choose Merge Calls. This call is added to the 
conference call.

Recording a Conference Call

Click the More (three dots) button to reveal the Start Call Recording menu. See page 26 
for more details.

Sending an Instant Message

Click the down arrow beside a participant name and choose Send Instant Message.

Participant menu

Conference call menu
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Removing a Participant

To remove one call from the conference, click the down arrow beside a participant name 
and choose Separate. The call becomes a separate call.

Ending the Conference

To hang up on everyone, click the End button.

Suspending the Conference

To suspend the conference, click the Hold button. All participants are put on hold.

If you need to speak to one participant separately, put the conference on hold, separate 
the one participant from the conference, take that person off hold. When done, merge the 
participant back into the call.

Video Conference Calls

Closing the video 
window stops sending 
video.

During a 
conference,“Video” 
appears beside each 
person.

Mute

When you mute during a video call, you may also want 
to click Stop Video to stop the video feed.

Display in full screen
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Starting a Conference with Video

When you start a conference from established calls, video is included if at least one of the 
calls already includes video. Video is sent to all the participants.

When you start a conference from scratch, video is not included. You can open your video 
window and choose to add video at any time. Video is sent to all the participants.

How Video Is Shared

The conference host (the person who starts the conference) serves as the host for other 
video. Whatever the conference host is receiving will automatically be sent to the other 
parties.

If the conference host pauses or stops video, other participants will no longer receive video.



26MAKING PHONE CALLS

   CALL RECORDING

You can record the audio portion of a one-to-one call or a conference call. The recording will be 
saved as a WAV file on your computer.

                    

Files Created when Recording Conference Calls

Multiple files might be created depending on how and when you start recording.

If you start recording a conference call from the beginning, the recording will continue until the 
conference call ends. One file will be created.

If you separate a participant from a recorded conference call and eventually have a one-to-one 
call, the recording will continue until the one-to-one call ends. Two files will be created : one for 
the conference call, and the other for the one-to-one call.

If you are already recording individual calls, the following will apply :

• After merging individual calls to form a conference, all the individual recordings will be 
stopped and a new recording will be created for the newly formed conference.

Click to start recording

The indicator appears.

Recording will end  
when the call ends.

To stop recording but continue 
with the call, click the square 
button beside the indicator, 
or click More and Stop Call 
Recording.

The dialog notifies where the 
recording is saved.
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• After merging individual calls to an existing conference call, all the individual recordings 
will be stopped. If the conference call is being recorded before merge, the recording of the 
existing conference call will continue.

For example, if you record two individual calls and merge them, three files will be created: one 
for the conference call, two for individual calls before merge.
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   VOICEMAIL

If your service includes voicemail and you have set up voicemail options, then when you have 
voicemail messages, the voicemail icon appears at the top of the phone (the icon may include 
a number). You can click the icon to automatically connect to voicemail and listen to your 
messages.

Voicemail icon
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   FORWARDING CALLS

                    
Click to forward call.
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   INSTANT MESSAGING 

Sending an IM

1 You can send an IM to a contact who is in your company and is using Ubity UC Desktop or Mobile.

From the Contacts tab Ctrl-click on the contact and choose Send IM. The contact must 
have a softphone address.

Or click on the IM icon that appears to the right of the contact 
name.

An active phone call If the person is a contact, choose Send Instant Message from 
the call panel menu.

An active conference call If the participant is a contact, choose Send Instant Message 
from the participant menu.

From the Messages window Click the New Conversation icon beside the Search field, and 
type a number or name.

2 Type the message. Include emoticons and formatting (Ctrl+B, Ctrl+I, Ctrl+U), as desired.

To insert a return in the message, press Ctrl+Enter.

3 Click the Send icon or press Enter.

Receiving an IM

When an IM is received, either the IM window or a notification pops up. (To control which 
window appears, from the menu choose Ubity UC Desktop > Preferences > Alerts & Sounds)

30MESSAGING

Click to select more actions
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   GROUP CHAT (CONFERENCE IM)

Group chat allows you to exchange instant messages with a group of people in the same 
session.

Group chat differs from a broadcast IM in that all parties see everyone’s messages, and the 
messages each party sends are seen by everyone else. In a broadcast IM, each recipient can 
reply to the IM, but only the person who sent the broadcast IM will see these replies ; the other 
recipients will not see these replies.

There is no limit to the number of participants in a group chat.

Starting a Group Chat
In the Messages window, select the 
desired contacts. Contacts must be online.

Type an invitation message and click Send.

Once a chat is started (first message has 
been sent), you cannot add or remove 
participants.
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Managing a Group Chat

Leaving a Group Chat

Exiting Ubity UC Desktop lets you leave all the active group chat sessions. The session 
continues with the remaining participants. Once you leave a group chat, you will not be able to 
rejoin the session. The thread in the Messages window becomes inactive (grayed out) ; you can 
read chat history, but cannot participate or download unread messages.

Deleting a group chat session on the Messages window also lets you leave the session, but 
you will lose chat history.

Ctrl-click over a contact to show options.
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   VIEWING MESSAGES

To view your recent IM activity for any contact, group chat session, or chat room session, 
perform one of these actions :

• Click the Messages window icon :

• Click Shift + Command + M.

• On the menu bar, choose View > Show Messages.

Messages window icon

Search all messages. Click for more actions 
such as exporting 
conversation.

The session may be greyed 
out. Typically it means that the 
account used for the session 
is not registered, or the group 
chat has ended.

Clicking the x icon deletes the session.
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   SENDING AND RECEIVING FILES 

Sending Files

Choose one of these actions :

1 Control-click a contact and choose Send Files ; a standard Open dialog box opens.

2 Select the files to send and click Open. The Send Files dialog appears with a “waiting” 
message. If you want, you can cancel the send before the other person retrieves the files by 
clicking Cancel.

Receiving Files

The following dialog appears, to allow you to save the file.
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4 — CONTACTS

The Contacts tab displays your contacts. Each contact is shown with presence information and 
icons for single- click phoning and IMing.

If the Contacts tab is not showing, go to the menu bar and choose View > Show Contacts.

You can change the detail and layout of the contact list : from the menu bar choose Contacts and 
set the desired options.

Search field

The online status of 
contacts. See page 42.

Add a contact

Contacts are typically organized 
into groups. Ubity UC Desktop 
includes built-in groups. You can 
add more groups, as desired.
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   ADDING A CONTACT

Adding a Contact Using an Existing Address

You can add a contact by capturing existing information :

• If you are on a phone call with a person who is not a contact, click the Add to Contacts 
icon in the Call panel.

• On the History tab, select an entry that is not a contact. Control-click and choose Add 
Contact. The Contact Profile dialog appears. Complete the dialog as desired and press OK.

If the contact method is Softphone or Instant Message, an online status request is sent to this 
person. See “Sharing Online Status” on page 41.

Manually Adding a Contact

Click  , or control-click a group and choose Add Contact to Group. The Contact dialog 
appears.

To enter a phone number, 
select the type, enter the 
number, and click +.

The new number appears in the list
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Contact Summary

Field Description

Contact Summary

Group Click to show the list of groups. Check each 
group this contact should belong to.

Primary call If the contact has more than one number, select 
the primary number. This number will be used 
with single-click calling.

Primary presence If the contact has more than one number, select 
the primary number. This number will be used 
with single-click calling and double-click calling.

Other Sections

Field Description

Display name (required) The display name for this source of information. 

First name, Last name This field appears only the contact has more than 
one Softphone number or Instant Message 
address. The primary presence is used as 
follows :

• The presence icon on the contact list shows the 
online status for this address.

• The single-click action for instant messaging 
uses this address.

You can still send IMs to this person at their other 
addresses, but you must right-click and choose 
from the context menu.

Other Sections

Display Name (required) The display name for this source of information. 
For example, the display name from the XMPP 
contact list.

First Name, Last Name Optional.
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Updating Contacts from the Directory

If you have created a contact created from directory, you can control-click the contact and 
choose Update from Directory in order to bring the latest directory information (if any) into 
the contact. Any key data you had added or changed in the contact may be overwritten by the 
update. Non-key data (such as the display name) will not be removed.

Changing Contact Information

To change the information for a contact, Ctrl-click the contact and choose Edit Profile. The 
Contact dialog appears (see page 40).

Merging and Splitting Contacts

You can drag one or more contacts to a contact. The dialog appears confirming that you want 
to merge contacts.

Deleting a Contact

• To delete one or more contacts, select them, Ctrl-click, and choose Delete or Delete 
Selected Items. The contacts are removed from this group. If a contact belongs to several 
groups, it is removed from all groups.
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   MANAGING GROUPS

Ubity UC Desktop has built-in groups. A contact must belong to at least one group. 

Adding, Deleting or Renaming Groups

Select any group, Ctrl-click, and choose the appropriate menu item.
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   USING CONTACTS

In the Contacts tab, you can :

• Double-click a contact to phone or IM (depending on how double-clicking is configured in 
Preferences > General).

• Click a contact to view the flyout

• Control-click to show the menu, or

• Hover over a contact to revel icons for single-click phoning or IMing.

You can watch the contact’s online status, if the contact 
has a softphone address.

See page 42 for the meaning of the online status icons.

See “Sharing Online Status” on page 41 for information 
on obtaining online status information.

Hover to reveal icons :

 Click to send an IM using the primary presence address for this contact.

 Click to call using the primary phone number.
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   SHARING ONLINE STATUS

Setting your Online Status

Changing your Status

Click the down arrow beside the online status indicator on Ubity UC Desktop, and select the 
desired value.

Setting up Status Indicators

You can create a custom status indicator : click the down arrow beside the status indicator, 
and double-click on one of the existing indicators ; type your custom status.

                    

Create a custom status indicator 
by clicking over your status.
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Status Indicators

Indicator Meaning for your Status Meaning for Others’ Status

 Available Either :

• You have set your status to this value.

• Ubity UC Desktop has determined that you are 
logged on but not on the phone or idle.

When you have this status, Ubity UC Desktop 
will automatically detect when you are Idle or 
On the phone, and change the status to match.

You can contact this person.

 Busy You have set your status to this value. Ubity UC 
Desktop will never automatically switch you out 
of this status ; you must switch yourself.

You can contact this person.

 Away You have set your status to this value. Ubity UC 
Desktop will never automatically switch you out 
of this status ; you must switch yourself.

You can contact this person.

 On the 
phone

Either :

• You have set your status to this value. In this 
case, Ubity UC Desktop will never automatically 
switch you out of this status ; you must switch 
yourself.

• You started a phone call when your status was 
“Available”. When your call finishes, your status 
reverts to “Available”.

You can contact this person.

 Do not 
disturb

You have set your status to this value. Ubity UC 
Desktop will never automatically switch you out 
of this status ; you must switch yourself.

You cannot contact this person.

 Not 
available for 
calls

You have set your status to this value. Ubity UC 
Desktop will never automatically switch you out 
of this status ; you must switch yourself.

You cannot contact this person.

 Idle You have not moved or clicked the mouse or 
pressed a keyboard key for the Idle period. 

As soon as you click the mouse or keyboard, 
your status changes to “Available”.

You can contact this person.
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Indicator Meaning for your Status Meaning for Others’ Status

 Appear 
offline

You have set your status to this value. The other 
person sees you as offline, even though you are 
actually online. The other person cannot tell the 
difference between this status and you really 
being offline.

The contact is either not logged 
on or does not want to share 
online status.

No icon Not applicable You are not watching the other 
person’s status.
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   ADDING CONTACTS TO THE ALERT LIST (BUDDY POUNCE)

You can add a contact to the Alert List in order to request to be notified when the online status 
of a contact changes.

                    

When the contact’s status changes, an alert appears :

In the contact list, control-click 
the selected contact or contacts 
and choose Add to Alert List.

The Alert List icon appears 
beside the contact.



5 — HISTORY

   HISTORY TAB

From the menu bar, choose View > Show History.

Managing the List of Calls

You can Ctrlclick on an entry in a list to :

• Delete the call.

• Delete all entries in this list.

• Edit the profile if the entry is a contact.

• Add as contact. The Contact dialog appears. See “Updating Contacts from the 
Directory” on page 38.

Phoning from History

You can :

• Ctrl-click on an entry and select Call or Video Call to place a call to this person, using the 
contact method that was used for this call.

• Place a call to this person and add them to a conference call that is in progress. For more 
information on conference calls, see page 21.

45HISTORY TAB

Down arrow : Incoming call 
that was answered

Red : Incoming missed call

Up arrow : Outgoing call,  
either attempted or established
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6 — TROUBLESHOOTING

Choose Help > Troubleshooting to display the Troubleshooting window.

   TESTING AUDIO QUALITY

While you are on a phone call, you can test the quality of the audio. Note that to perform a valid 
test, you should be on an established call (not a call attempt).
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   TESTING VIDEO QUALITY

While you are on a video call, you can test the quality of the video. Note that to perform a valid 
test, you should be on an established call (not a call attempt).
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   TESTING AUDIO DEVICES

You can verify that your microphone and speakers are working and can set the volume to a 
comfortable level without having to actually place a phone call.
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7 — CONFIGURING PREFERENCES

From the menu bar, choose Ubity UC Desktop > Preferences. The Preferences window appears. 
These tabs (except for the Accounts tab) let you control the way that you work with Ubity UC 
Desktop.

   PREFERENCES – APPLICATION

This panel lets you set your preferences for general GUI behavior and lets you set up for login.

Default Actions

This feature lets you control the action performed for two buttons :

• The green Call button at the top of the phone. For example, you can configure the button 
so that it makes a video call instead of an audio call.

• The Transfer button. For example, you can configure the button so that it initiates 
unattended (transfer now) transfer instead of an attended (call first) transfer.
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   PREFERENCES – ALERTS & SOUNDS

This panel lets you control the alert box and lets you assign sounds.

Enable Alert Displays

• You can control whether notifications are displayed in different situations. To receive 
notifications, notifications must also be set up to use either Banners or Alerts under OS’s 
system preferences. When “Enable alert displays” is on, Ubity UC Desktop shows either a 
banner or an alert for selected situations.

• There are two choices on how you are alerted to an incoming IM : either with a small 
notification pop-up or with the Messages window itself. To be alerted with the Messages 
window instead of notifications, “For an Incoming Message” must be turned off.

Assigning Sounds

You can assign specific sounds to a variety of actions or “events”.

1 Select the Enable sounds check box and select the check boxes for each desired event, 
or clear the Enable sounds check box to disable all sounds.

2 If enabling sounds, you can change the sound for each event : select the individual event. 
The value in Sound preference will change. Select the desired sound.

You can import sounds ; these will be added to the list of sounds you can choose from when 
assigning a sound to an event.
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   PREFERENCES – DEVICES

Ubity UC Desktop automatically detects devices at each startup, and selects the most 
appropriate device for each purpose. If you do not like this selection, you can override it on this 
panel.

If you override a selection, it will apply the next time you start Ubity UC Desktop, unless the 
device is no longer available, in which case Ubity UC Desktop will again select the device to 
use.

Field Description

Automatic gain control On to automatically adjust the audio gain.

Reduce background noise Automatically attempts to remove background 
noise. Typically on for the speakerphone.

Test Devices For information on the Test Devices button, see 
“Application Hot Keys” on page 57.

Test Camera Click to check if Ubity UC Desktop can use your 
camera. The video window opens, and shows a 
message.



52CONFIGURING PREFERENCES

Field Description

Headset Mode

Microphone, Speaker Change these fields only if you want to override 
the devices that Ubity UC Desktop automatically 
selected. In both these fields, select the headset 
you are using.

The headset is the device that is usually used 
for the Speaker (the sound you hear) and 
Microphone (recording your voice). The only 
situation in which the headset is not used is when 
the Speaker Phone button on the dialpad is 
pressed.

Therefore, unless you will always be using Ubity 
UC Desktop in Speakerphone mode, you must 
make a selection here.

Select the headset in both the Speaker device 
field and Microphone device field.

Speakerphone Mode

Speaker 

Microphone

Same as headset mode, but for the device to use 
when speakerphone is one (on the toolbar).

Select None if you do not have a speaker phone. 
The Speaker Phone button on the dialpad will be 
disabled.

You can set different devices for the Speaker 
and Microphone : for example, you can set 
the speaker to the speakerphone and set the 
microphone to your headset.

Reduce echos Turning this feature on improves sound quality. 
This feature is typically on.

Other Device

Ring On The device where you want to hear the phone 
ringing.

Change this field only if you want to override the 
devices that Ubity UC Desktop automatically 
selected.



53CONFIGURING PREFERENCES

Field Description

Camera This field appears only on versions of Ubity UC 
Desktop that include Video functionality.

Change this field only if you want to override the 
devices that Ubity UC Desktop automatically 
selected. Select the camera model.

Max Resolution Leave at standard, or change the size as follows :

• Set it to high if you have a good camera and a 
computer with a fast CPU. You will know that you 
have set the size too large if :

Your computer slows down (the video is using too 
much CPU) or the video shows black areas or is 
slow or jerky.

• Typically set it to low only in special situations, 
for example, when using Wi-Fi in a hotel. You will 
know that you have set the size too small if the 
video is fuzzy.
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   PREFERENCES – CALLS

These settings let you configure how you want auto answer to handle incoming calls, when 
Auto Answer is enabled. (To enable Auto Answer, see page 14).

Field Description

Answer Calls These settings let you configure how you want 
auto answer to handle incoming calls, when Auto 
Answer is enabled. (To enable Auto Answer, see 
page 14)
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Field Description

DTMF You may need to change the DTMF configuration 
if you cannot interact with interactive voice 
response systems (auto attendants, voice-
activated menus, and so on).

Contact your VoIP service provider or your 
system administrator for the correct setting.

In-band means that Ubity UC Desktop will 
encode the DTMF signals in the audio stream as 
regular sound. Typically, DTMF is not sent in-
band; in-band is only used in specific situations.

One scenario in which it might be advisable to 
send in-band is if you own your gateways and :

• One or more of these gateways does not 
support RFC 2833 or does not handle it well, and

• Your gateway is using codes that reproduce 
DTMF tones well.

In this case, sending in-band will ensure that 
DTMF tones get through (because the DTMF 
tones will bypass the gateway) and that they 
reproduce accurately at the receiving end.

RTP This timer controls how calls are disconnected 
when Ubity UC Desktop determines that there is 
a problem with the call and the other party has 
probably disappeared (assuming that you have 
not yourself detected the problem and hung up 
manually).

• Typically, the timer is enabled. It is 
recommended that you not disable it. You can 
change the length of the timer, but do not set it to 
less than 30 seconds.

Preserve bandwidth When this feature is on, Ubity UC Desktop stops 
sending audio when you are not talking.

When this feature is off, Ubity UC Desktop always 
sends audio, which uses more bandwidth but 
may result in better call quality.

Typically off. However, if you are using a slow 
(dial-up or ISDN) connection, you may want to 
turn it on.
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   PREFERENCES – ADVANCED

Field Description

Recording folder The folder where files for recording of phone calls 
will be saved.

File transfer folder The folder where received files will be saved.
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8 — APPLICATION HOT KEYS

Function Keyboard Shortcut

Making or answering a call

Answer an incoming call Ctrl + N

Decline an incoming call Ctrl + D

Redial the last dialed number Ctrl + R
or Ctrl + R then Enter

End the call
End the conference call (hang up on all participants)

Ctrl + E

During a call

Mute your voice during a call Ctrl + M

Hold or resume the call when the focus is on this call panel Ctrl + H

Transfer an established call when the focus is on this call panel Ctrl + T

Opening a window

Open the Messages window Shift + Apple key + M

Open the Preferences window Apple key + ,  
(comma)

Open the Test Devices window Ctrl + 9

Open the Video window Shift + Apple key + V

Text Handling

Select all Apple key + A

Copy text Apple key + C

Paste text Apple key + V

Cut text Apple key + X

Hiding

Hide Ubity UC Desktop Apple key + H

Exiting

Quit Ubity UC Desktop Apple key + Q


