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4GETTING STARTED

1 — GETTING STARTED

   STARTING UBITY UC DESKPTOP

Install Ubity UC Desktop

Verify the status of your extension on the Ubity web interface, Studio (https://admin.ubity.com), 
in Management > Extensions > My extension. Next to your extension you will see the UC 
symbol.

If the UC is not activated on your extension, please contact the administrator of your account 
so that he can place an email request to our technical support at support@ubity.com to activate 
it.

Note : The activation of UC can generate additional monthly costs.

Download the appropriate setup executable file of Ubity UC Desktop for your computer via 
Install UC Software and follow the prompts in the install wizard.

    

Start Ubity UC Desktop

Start Ubity UC Desktop as you would any other program : Use the Windows Start menu or 
double-click the desktop icon. The Ubity UC Desktop dialog appears.

Ubity UC Desktop icon

Download the executable 
Ubity UC Desktop installation 
file from here.

UC icon when it is 
activated, versus not 
activated :
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   IDENTIFY YOURSELF

Once the software is downloaded and installed, and you have started it by double-clicking the 
Ubity UC Desktop icon, you will be asked for a username and password. These credentials 
are the same as the ones you use on Ubity’s web management portal, commonly referred as 
Studio (studio.ubity.com).

Username: the username used to log into the Ubity management portal

Password: the password used to log into the Ubity management portal

If you don’t yet have a password, or can’t remember your password, you will have to request 
a new one by clicking on the “Recover your password” link on Studio’s login page (at the 
address above).

By checking the Remember password box, you will be automatically logged in each time you 
launch the software, without having to enter your username and password.
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    TEST YOUR EQUIPMENT

It is important to make a test call to ensure that your microphone, your headset and/or your 
camera work correctly. If this is not the case, you should contact an IT manager to help you set 
them.
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   MAKING A FIRST CALL

Try making calls with your new phone (page 9).

Having Troubles ?

Ubity UC Desktop includes these tools for helping you troubleshoot problems. From the menu, 
choose Help > Troubleshooting (page 46) to access these tabs.

Verify your camera 

You can verify that your camera is working by going to Preferences > Devices > Test Camera

Verify your microphone and speakers 

You can verify that your microphone and speakers are working by going to the Device tab. You 
can set the volume to a comfortable level without having to actually place a phone call.

Verify that you are connected

You can verify that you are successfully connected by going to the Audio tab. While you are on 
a phone call, you can test the quality of the audio.

Ask costumer support

If none of the above help you solve your problem, go to the Support tab. You can create logs of 
your activity and send them to customer support.
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   QUITTING UBITY UC DESKTOP

To quit Ubity UC Desktop, choose Softphone > Exit or press Control-Q.

   CHECKING FOR UBITY UC DESKTOP UPDATES

If you are in an enterprise, your system administrator should tell you about the policy for 
checking for and installing upgrades.

To check for updates to Ubity UC Desktop, choose Help > Check for Updates. The Auto 
Update window appears.

             

If a new version of the software is available, you can download it from this window.

If no newer version is available, this window informs you that your version is up to date.
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2 — MAKING PHONE CALLS

   THE ONSCREEN SOFTPHONE

Ubity UC Desktop 
menu. See below.

Change layout of contact list 
and import contacts

Show/hide resources such as contacts, favorites 
and modules such as chat rooms.

Call entry field. See page 13.

Missed calls indicator.

Close to system tray. This icon does 
not shut down Ubity UC Desktop

Minimize to system tray

Open the Messages window. 
See page 34.

Voicemail indicator.  
See page 27.

Detach the tab from the 
main window.
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   THE UBITY UC DESKTOP MENU

Softphone

Preferences

These settings control the way that you work with Ubity UC Desktop and apply to all 
accounts. See “Configuring Preferences” on page 49.

Log Out

To log off and minimize Ubity UC Desktop to the system tray. If you click the Ubity UC 
Desktop icon in the status bar, the Login screen appears. This menu item does not appear 
if you have configured Ubity UC Desktop for no login.

Exit

Click to shut down Ubity UC Desktop. You can also exit by pressing Ctrl-Q.

View

Changes how Ubity UC Desktop looks. Also lets you view the messages (see page 34).

Contacts

Lets you work with contacts.

Help

Provides access to various service-related features.

Compact View

To create this compact view, go to Ubity UC Desktop, click View and hide all pannels (Dialpad, 
Contacts and History) by removing the check marks.
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   PLACING A CALL

Place the call as described in the table below. The outgoing call opens in its own Call panel, 
below any other Existing call panels. You will hear a ringing tone while Ubity UC Desktop 
attempts to make a connection.

Option From the... Description

Keying Dialpad or computer 
keyboard

1 Enter the phone number in the call entry field 
using the dialpad or the computer keyboard. To 
turn letters to numbers, see page 12.

As you type, a suggestion for completing the entry 
may appear. Choose the suggestion by using the 
Up/Down key and the Tab key, or keep typing.

2 Ubity UC Desktop makes a call as soon as you 
choose the suggestion. If you do not want to 
choose a suggestion, finish typing and click the 
Call button or press Enter.

Right-click a contact 
or previous call

Contacts or History 
tab

Right-click an entry from the Contacts or History 
tab and choose Call.

Double-click a 
contact

Contacts tab Contacts have a “double-click” action (page 52) 
that either makes an audio phone call or starts an 
IM.

Single-click a 
contact

Contacts tab Hover over the right side of the contact to reveal 
the click-to-call button. Click to place a call using 
the primary phone number for this contact.

Double-click a 
previous call

History tab Double-click an entry. An audio call is placed.

Redial Redial button • When the call entry field is empty, click the Call 
button.

• Or click the arrow in the call entry field and select 
a recent call.

An audio call is placed.

Dialing Dialpad 1 If the dialpad is not visible, click the Phone 
button at the bottom left. 

2 Click the numbers on the dialpad to enter the 
phone number.

3 Click the Call button or press Enter.
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Option From the... Description

From an instant 
message

Messages window Click the menu at the top right of the Messages 
window and choose Call.

    

Selecting the Account to Use

This information applies only if you have more than one Ubity UC number set up and enabled.

When you place a call, you can explicitly specify the account to use for that call.

The account selection options appear only if you have two or more Ubity UC numbers that are 
enabled and being used for phone calls. 

Letters to Numbers

You can type letters and Ubity UC Desktop will convert the letters to numbers when placing the 
call :

Call entry 
field

The Call icon

Auto Complete suggestions. Ubity UC Desktop makes a call as soon 
as you choose the suggestion. You can change this behavior so Ubity 
UC Desktop does not dial until the Call button is pressed (page 50).

Clicking the down arrow gives you more call 
options, such as video call or conference call.

For information on working with the call, see 
“Handling an Established Call” on page 16.

Type the phone 
number using numbers 
and letters, as desired.

When you click Call, the call panel will open 
and the call will be placed. The call panel will 
show the phone number all in numbers.

Turn Letter-to-numbers on or off.
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Placing another Call

You can place another call. On Ubity UC Desktop, you can make up to five concurrent calls.

        

Dialing additional numbers

             

Place the call in the usual way 
(see page 11).

Existing call is 
automatically put 
on hold.

New outgoing call.

Switch between the different calls by clicking 
Resume on the desired call panel. That call 
becomes the active call and all other calls 
are put on hold.

Place your 
cursor below the 
contact’s number 
to activate the 
extension entry 
field.

Type in the number 
of the option or the 
extension you wish 
to reach when you 
are invited to do so.
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   HANDLING INCOMING CALLS

Ubity UC Desktop must be running to answer incoming calls. It can be running in the system 
tray.(If Ubity UC Desktop is not running, incoming calls may be directed to voicemail.

The new call appears in its own Call panel. In addition, the Call Alert box appears. For 
information on setting call alert preferences, see page 53.

             

             

This is the alert for both 
audio and video calls :

Click to answer the call. If you are on another 
call, that first call is automatically put on hold. 
You are now talking to the new caller.

Or click Forward ; a call entry 
field appears. Enter the name or 
number to forward to and click 
Forward Now.

Or click to refuse the call.  
The caller will hear a busy 
signal or the call may be 
directed to voicemail  
(if you have this service).
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Auto Answer

Auto Answer is initially configured to auto- answer after one ring, and to send only your audio 
when the call is established. To change this configuration choose Softphone > Preferences > 
Calls.

Auto Answer is turned off when you shut down or log off.

Disabling Call Waiting

You can turn on Disable Call Waiting. If on, when you are on a call, any new incoming call will 
go straight to voicemail or will ring as busy (to the caller). In this way, you are not distracted by 
incoming calls.

You can enable this feature even during a call, and it will take effect right away. The call will 
appear in the Missed Calls in the History tab.

Turn Auto Answer on or off.

Disable Call Waiting on or off

A check mark indicates the feature 
is enabled (no interruption during 
a call).
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   HANDLING AN ESTABLISHED CALL

Ending a Call

Click the red End call button on the Call panel (the call can be active or on hold). The Call 
panel closes after a few seconds.

Use speakerphone (when yellow) 
or headset (when gray).

Place another call.

The current call is automatically 
put on hold. See page 14 for more 
information.

Mute your voice

Hold and resume.

Transfer. See page 17.

Start sending video. 
See page 19.

Mute speaker or adjust speaker 
volume by using slider.

You can disable call waiting. 
See the previous page.

Add as Contact. 
Add the current caller as a contact.  
See “Managing Groups” on page 38.

Conference Calls. See page 21 
Instant Message. See page 29 
Record the call as a WAV file (audio 
only). See page 25.
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   TRANSFERRING A CALL

Basic (Unattended) Transfer – Transfer this Call

             

             

Click the Transfer button

The call is put on hold 
and a call entry field 
appears.

Type a name or 
number, or drag a 
contact into the field.

Then click 
Transfer Now.

If the button does not show “Transfer now”, click the down arrow and 
select Transfer now. You can also permanently change the option that 
appears on the button; see page 50.

The call ends 
immediately.
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Attended Transfer – Call then Transfer

You can first speak to the target (the person you are transferring the call to), then click Transfer 
Now to complete the transfer.

             
Click the Transfer button.

The call is put on hold and a call entry field appears.

If the button does not 
show “Call first”, click 
the down arrow and 
select Call First. You 
can also permanently 
change the option that 
appears on the button; 
see page 49.

Type a name or number, or drag a contact 
into the field, then click Call First.

Ubity UC Desktop phones 
the new person.

When the other person 
answers, the Transfer Now 
button is enabled.

You can hang up the second call and 
return to the first call. 

Or if the other person does not want 
to take the call, click Cancel and 
return to the first call.When you are ready, click  

Transfer Now. The Call panel closes.
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   HANDLING VIDEO CALLS

Placing a Video Call

Calls made with Ubity UC Desktop will work without a video camera, but a video camera is 
necessary to allow other parties to see your image. Ubity UC Desktop will work with most USB 
video cameras. This option needs to be enabled in Ubity’s web management portal, Studio, in 
the extension settings.

From the Dashboard

From the Contact List or History

Type an number and click the 
down arrow and choose Video 
Call.

Right-click the contact and 
Choose Video Call.
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Adding Video

If you have a camera, you can add video to a call that started as an audio call.

Click Start Video in the Call panel. When you add video, the other party may (or may not) start 
sending their video to you.

Other Party Adds Video

If the other party starts their video, your video window automatically opens and the video is 
played. You can start sending your own video, if desired (and assuming you have a camera) by 
clicking Start Video (  ) in the Call panel.

Pausing and Resuming Video

Click Stop Video in the Call panel or close the video window to pause sending your video. 
Click Start Video to resume sending your video ; the video window will open.

Start or Stop sending your video.

To view in full screen, hover over the 
video window and click the two-way 
arrow icon, or press F11 when the 
focus is on the video window.

Click to configure the camera.

Display in full screen
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   CONFERENCE CALLS

Starting a Conference Call

You can start a conference call by :

• making a conference call from the dashboard,

• adding participants to an existing established call, or

• having two established calls and merging them to a conference call.

From the Dashboard

      Enter the number or address by 
typing, or select from the redial list.

Click the down arrow and choose Start 
Conference Call and click click Add.
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From an Existing Call

From One Established Call 

From Two Established Calls

You can add more participants 
from here.

You can merge two 
established calls.

Invite to Conference Call will 
allows you to add a third person to 
the call.
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Managing the Conference

Adding More Participants

You can add more participants to an existing conference in any of these ways :

• Right-click on a contact or history item and choose Add to Conference Call.

• In the conference call panel, click Invite to Conference Call, enter a name and click 
Add.

• Add in a separate call that is not part of the conference call : in the Call panel for the 
individual call, click the down arrow and choose Merge Calls. This call is added to the 
conference call.

Recording a Conference Call

Click the More (three dots) button to reveal the Start Call Recording menu. See page 26 
for more details.

Sending an Instant Message

Click the down arrow beside a participant name and choose Send Instant Message.

Removing a Participant

To remove one call from the conference, click the down arrow beside a participant name 
and choose Separate. The call becomes a separate call.

Click the arrow for 
Participant menu.
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Ending the Conference

To hang up on everyone, choose End conference from the conference menu.

Suspending the Conference

To suspend the conference, choose Hold from the conference menu. All participants are put 
on hold.

If you need to speak to one participant separately, put the conference on hold, separate 
the one participant from the conference, take that person off hold. When done, merge the 
participant back into the call.

Video Conference Calls

Calls made with Ubity UC Desktop will work without a video camera, but a video camera is 
necessary to allow other parties to see your image. Ubity UC Desktop will work with most USB 
video cameras (This option must be enabled in Studio).

             

Including Video in a Conference

When you start a conference from established calls, video is automatically included if at 
least one of the calls already includes video and is sent to all the participants.

When you start a conference from scratch, video is not included. You can open your video 
window and choose to add video at any time. Video is sent to all the participants.

How Video is Shared

The conference host (the person who starts the conference) serves as the host for other 
video. Whatever the conference host is receiving will automatically be sent to the other 
parties.

If the conference host pauses or stops video, other participants will no longer receive video.

Mute When you mute during a video call, you may also 
want to click Stop Video to stop the video feed.

“Video” next to the contact name means this person has video. 
Otherwise, the person does not. To remedy this situation, stop video 
and start it again. Video will be sent to all the current participants.

Closing the video 
window stops 
sending video.
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   CALL RECORDING

You can record the audio portion of a one-to-one call or a conference call. The recording will be 
saved as a WAV file on your computer.

             

Files Created when Recording Conference Calls

Multiple files might be created depending on how and when you start recording.

If you start recording a conference call from the beginning, the recording will continue until the 
conference call ends. One file will be created.

If you separate a participant from a recorded conference call and eventually have a one-to-one 
call, the recording will continue until the one-to-one call ends. Two files will be created : one for 
the conference call, and the other for the one-to-one call.

If you are already recording individual calls, the following will apply :

• After merging individual calls to form a conference, all the individual recordings will be 
stopped and a new recording will be created for the newly formed conference.

Click to start recording

The indicator starts flashing.

The dialog notifies 
where the recording is 
saved.

Recording will end when the call ends.

To stop recording but continue with the call, click 
the square button beside the indicator, or click 
More and Stop Recording Call.
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• After merging individual calls to an existing conference call, all the individual recordings 
will be stopped. If the conference call is being recorded before merge, the recording of the 
existing conference call will continue.

For example, if you record two individual calls and merge them, three files will be created : one 
for the conference call, two for individual calls before merge. 
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   VOICEMAIL

You can click the voicemail icon from the dialpad to automatically connect to voicemail and 
listen to any messages.

Voicemail icon
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   FORWARDING CALLS

             

During an incoming call, click the 
Forward button to forward the 
call.

Enter the number you wish to 
forward to, and click Forward.



29SECTION TITLE



30SECTION TITLE



3 — MESSAGING

   INSTANT MESSAGING 

Sending an IM

1 You can send an IM to a contact who is in your company and is using Ubity UC Desktop or 
Mobile.

From the Contacts tab Right-click on the contact and choose Send Instant Message. 
The contact must have a softphone address.

Or click on the IM icon that appears to the right of the contact 
name.

An active phone call If the person is a contact, choose Send Instant Message from 
the call panel menu.

An active conference call If the participant is a contact, choose Send Instant Message 
from the participant menu.

From the Messages window Click the New Conversation icon beside the Search field, and 
type a number or name.

2 Type the message. Include emoticons and formatting (Control+B, Control+I, Control+U), as 
desired.

To insert a return in the message, press Shift+Enter. You can control the behavior of Enter and 
Shift+Enter on the Softphone > Preferences > Application panel.

31MESSAGING

Click here to open the 
Messages window.
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3 Click the Send icon.

Receiving an IM

When an IM is received, either the Messages window or a Call Alert pops up. (To control 
which window appears, choose Softphone > Preferences > Alerts & Sounds.)

             

Click to select 
more actions.

New Message alert :

New Message indicator. 
Click on this icon to open 
the Messages window.

Send icon
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   GROUP CHAT (CONFERENCE IM)

Group chat allows you to exchange instant messages with a group of people in the same 
session. 

There is no limit to the number of participants in a group chat session.

Starting a Group Chat

1 Open the Messages window

2 Add the recipients you want to include in the group chat

3 Type a message and click the Send icon. Once a chat is started (first message has been 
sent), you cannot add or remove participants.

      

Managing a Group Chat

Select the desired contacts. Contacts must be online.

Type a message and click the Send icon. Once a chat is started (first message has been sent), you cannot 
add or remove participants.

Right-clicking on a contact shows actions you can take

Clicking on the icon   
allows you to export or 
delete the conversation.
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Leaving a Group Chat

Log out lets you leave all the active group chat sessions. The session continues with the 
remaining participants. Once you leave a group chat, you will not be able to rejoin the session. 
The thread in the Messages window becomes inactive (grayed out) ; you can read chat history, 
but cannot participate or download unread messages.

Deleting a group chat session on the Messages window also lets you leave the session, but 
you will lose chat history.
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   VIEWING MESSAGES

To view your recent IM activity for any contact, group chat session, or chat room session, 
perform one of these actions :

• Click the Messages window icon :

• Click Shift + Control +M.

• On the menu, click View > Messages.

             
Right-click to 
save or delete a 
conversation.

Search all messages
Clicking the x icon deletes 
the session.

You can copy the messages.

The session may be grayed out. Typically it 
means that the account used for the session is 
not registered, or the group chat has ended.
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   SENDING AND RECEIVING FILES 

Sending Files

Choose one of these actions :

• Right-click a contact and choose Send Files ; a standard Open dialog box opens. Select 
the files to send and click Open.

• Drag a file from a folder to the IM session of the Messages window.

The Send Files dialog appears with a “waiting” message. To cancel the file transfer before the 
other person retrieves the files, click Cancel.

Receiving Files
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The file is saved to the location specified in Preferences > Files & Webs tabs.
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4 — CONTACTS

The Contacts tab displays your contacts. Each contact is shown with presence information and 
icons for single- click phoning and IMing.

If the Contacts tab is not showing, go to the main menu and choose View > Show Contacts.

Contacts are typically organized into groups. Ubity UC Desktop includes built-in groups. You can 
add more groups, as desired.

You can change the detail and layout of the contact list : from the main menu choose Contacts and 
set the desired options.

Search entire contact list Detach list from main window

Add a Contact

Contacts are typically organized into 
groups. Ubity UC Desktop includes 
built-in groups. You can add more 
groups, as desired.
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   ADDING A CONTACT

Adding a Contact Using an Existing Address

You can add a contact by capturing existing information :

• If you are on a phone call with a non-contact, click the Add to Contacts button in the Call 
panel.

• On the History tab, select an entry that is not a contact. Right-click and choose Add as 
Contact.

The Contact Profile dialog appears. Complete the dialog as desired and press OK.

Manually Adding a Contact

Click  , or right-click a group and choose Add Contact to Group. The Contact Profile 
dialog appears.

To enter a phone 
number, select the type, 
enter the number, and 
click Add.

The new number appears in the list.
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Contact Profile Summary

Field Description

Display as If several display names are available, choose the 
one that you want to show in the contact list.

Group Click to show the list of groups. Check each 
group this contact should belong to.

Primary presence The primary presence is used as follows :

• The presence icon on the contact list shows the 
online status for this address.

• The single-click and double-click actions for 
instant messaging use this address.

You can still send IMs to this person at their other 
addresses, but you must right-click and choose 
from the context menu.

Primary phone number If the contact has more than one number, select 
the primary number. This number will be used 
with single-click calling and double-click calling.

Other Sections

Field Description

Display name (required) The display name for this source of information. 

First name, Last name Optional.

Changing Contact Information

To change the information for a contact, right-click the contact and choose Edit Profile. The 
Contact Profile dialog appears (page 38).

Merging and Splitting Contacts

To merge contacts, you can drag one or more contacts to a contact. The dialog appears 
confirming that you want to merge contacts.

Moving or Deleting a Contact

• To drag one or more contacts to a different group, select them and drag to the title bar of 
the new group.
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• To delete one or more contacts, select them, right-click, and choose Delete Contact or 
Delete Selected. The contacts are removed from this group. If a contact belongs to several 
groups, it is removed from all groups.
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   MANAGING GROUPS

Ubity UC Desktop has built-in groups. A contact must belong to at least one group.

Adding, Deleting or Renaming Groups

Select any group, right-click, and choose the appropriate menu item.
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   USING CONTACTS

In the Contacts tab, you can :

• Double-click a contact to phone or IM (depending on how double-clicking is configured in 
Preferences > Application).

• Click a contact to view the flyout

• Right-click to show the menu, or

• Hover over a contact to revel icons for single-click phoning or IMing.

Click a contact to view the flyout.

Hover to reveal icons. 

   

Click the phone icon to call 
using the primary phone 
number. 

Or click the IM icon to send an 
IM using the primary presence 
address for this contact.

Or right-click and choose from 
the menu.

You can watch the contact’s 
online status, if the contact is 
part of your company and uses 
a Ubity phone or softphone.

See the table on page 43 for 
the meaning of the online 
status icons.

See “Sharing Online Status” 
on page 42 for information 
on obtaining online status 
information.
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   SHARING ONLINE STATUS

Setting your Online Status

Changing your Status

Click the down arrow beside the online status indicator on Ubity UC Desktop, and select the 
desired online status.

             

Your online 
status

Online status 
of other 
people
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Status Indicators

Indicator Meaning for your Status Meaning for Others’ Status

 Available Either :

• You have set your status to this value.

• Ubity UC Desktop has determined that you are 
logged on but not On the phone or Idle.

When you have this status, Ubity UC Desktop 
will automatically detect when you are idle or on 
the phone, and change the status to match.

You can contact this person.

 Busy You have set your status to this value. Ubity UC 
Desktop will never automatically switch you out 
of this status ; you must switch yourself.

You can contact this person.

 Away You have set your status to this value. Ubity UC 
Desktop will never automatically switch you out 
of this status ; you must switch yourself.

You can contact this person.

 On the 
phone

Either :

• You have set your status to this value. In this 
case, Ubity UC Desktop will never automatically 
switch you out of this status ; you must switch 
yourself.

• You started a phone call when your status was 
“Available”. When your call finishes, your status 
reverts to “Available”.

You can contact this person.

 Do not 
disturb

You have set your status to this value. Ubity UC 
Desktop will never automatically switch you out 
of this status ; you must switch yourself.

You cannot contact this person.

 Not 
available for 
calls

You have set your status to this value. Ubity UC 
Desktop will never automatically switch you out 
of this status ; you must switch yourself.

You cannot contact this person.

 Appear 
offline

You have set your status to this value. The other 
person sees you as offline, even though you are 
actually online. The other person cannot tell the 
difference between this status and you really 
being offline.

The contact is either not logged 
on or does not want to share 
online status.

No icon Not applicable You are not watching the other 
person’s status.
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   ADDING CONTACTS TO THE ALERT LIST (BUDDY POUNCE)

You can add a contact to the Alert List in order to request to be notified when the online status 
of a contact changes.

Right-click the contact or contacts and choose Add to Alert List. The Alert List icon appears 
beside the contact :

             

When the contact’s status changes, a notification appears :

Right-click the contact or contacts 
and choose Add to Alert List.

Alert List icon

Click to keep the contact on the alert 
list ; the next time the contact’s status 
changes, another notification will appear. 
Or leave unchecked to stop receiving 
notifications. The time at which the 

contact’s status changed.

Click to phone or 
IM this person.
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   HISTORY TAB

To view the History tab, go to the main menu and choose View > Show History.

Managing the Lists of Calls

You can right-click on an entry in a list to :

• Delete the entry.

• Delete all entries in the list.

• Edit the profile if the entry is a contact.

• Add as contact. The Contact Profile appears (page 38).

Phoning from History

You can :

• Right-click on an entry to place a call to this person, using the contact method that was 
used for this call.

• Double-click to place an audio call.

• Place a call to this person and add them to a conference call that is in progress.  
For more information on conference calls, see page 22.
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Red: Incoming missed 
call

Up arrow: Outgoing call, either 
attempted or established

Down arrow: Incoming 
call that was answered

Detach list from main window.
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6 — TROUBLESHOOTING

Choose Help > Troubleshooting to display the Troubleshooting window.

   TESTING AUDIO DEVICES

You can verify that your microphone and speakers are working and can set the volume to a 
comfortable level without having to actually place a phone call.
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   TESTING AUDIO QUALITY

While you are on a phone call, you can test the quality of the audio. Note that to perform a valid 
test, you should be on an established call (not a call attempt).
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   TESTING VIDEO QUALITY

While you are on a video call, you can test the quality of the video. Note that to perform a valid 
test, you should be on an established call (not a call attempt).
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7 — CONFIGURING PREFERENCES

Choose Softphone > Preferences. The Preferences window appears.

The Preferences panels let you control the way that you work with Ubity UC Desktop. It also 
contains fields to configure features that apply globally, rather than on a per-account basis.

   PREFERENCES – APPLICATION

This panel lets you set your preferences for general GUI behavior and lets you set up for login.
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Default Actions

This feature lets you control the action performed for two buttons :

• The green Call button at the top of the phone. For example, you can configure the button 
so that it makes a video call instead of an audio call.

• The Transfer button. For example, you can configure the button so that it initiates 
unattended (transfer now) transfer instead of an attended (call first) transfer.



53CONFIGURING PREFERENCES

   PREFERENCES – ALERTS & SOUNDS

The tabs on this panel let you control the Call Alerts box and lets you assign sounds.

Alerts

You can control whether the Call Alert box is displayed in different situations.

You can also control how you are alerted to an incoming IM : either with a small IM Alert box or 
with the Messages window itself. 

Sounds

You can assign specific sounds to a variety of actions or “events”.

1 Select the Enable sounds check box and select the check boxes for each desired event, or 
clear the Enable sounds check box to disable all sounds.

2 You can change the sound for each event : select the individual event. The value in Sound 
preference will change. Select the desired sound.

You can import sounds ; these will be added to the list of sounds you can choose from when 
assigning a sound to an event.
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   PREFERENCES – DEVICES

Ubity UC Desktop automatically detects devices at each startup, and selects the most 
appropriate device for each purpose. If you do not like this selection, you can override it on this 
panel.

If you override a selection, it will apply the next time you start Ubity UC Desktop, unless the 
device is no longer available, in which case Ubity UC Desktop will again select the device to 
use.

Field Description

Automatic gain control On to automatically adjust the audio gain.

Reduce background noise Automatically attempts to remove background 
noise. Typically on for the speakerphone.

Test Devices For information on the Test Devices button, see 
“Application Hot Keys” on page 59.

Test Camera Click to check if Ubity UC Desktop can use your 
camera. The video window opens, and shows a 
message.
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Field Description

Headset Mode

Microphone, Speaker Change these fields only if you want to override 
the devices that Ubity UC Desktop automatically 
selected. In both these fields, select the headset 
you are using.

The headset is the device that is usually used 
for the Speaker (the sound you hear) and 
Microphone (recording your voice). The only 
situation in which the headset is not used is when 
the Speaker Phone button on the dialpad is 
pressed.

Therefore, unless you will always be using Ubity 
UC Desktop in Speakerphone mode, you must 
make a selection here.

Select the headset in both the Speaker device 
field and Microphone device field.

Speakerphone Mode

Speaker/Microphone Same as headset mode, but for the device to use 
when speakerphone is one (on the toolbar).

Select None if you do not have a speaker phone. 
The Speaker Phone button on the dialpad will be 
disabled.

You can set different devices for the speaker 
and microphone : for example, you can set the 
speaker to the Speaker Phone and set the 
Microphone to your headset.

Reduce echos Turning this feature on improves sound quality. 
This feature is typically on.

Other Device

Ring On The device where you want to hear the phone 
ringing.

Change this field only if you want to override the 
devices that Ubity UC Desktop automatically 
selected.
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Field Description

Camera This field appears only on versions of Ubity UC 
Desktop that include video functionality.

Change this field only if you want to override the 
devices that Ubity UC Desktop automatically 
selected. Select the camera model.

Max Resolution Leave at standard, or change the size as follows :

• Set it to high if you have a good camera and a 
computer with a fast CPU. You will know that you 
have set the size too large if :

Your computer slows down (the video is using too 
much CPU)

The video shows black areas or is slow or jerky.

• Typically set it to low only in special situations, 
for example, when using Wi-Fi in a hotel. You will 
know that you have set the size too small if the 
video is fuzzy.
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   PREFERENCES – SHORTCUT KEYS

You can enable shortcut keys to several functions.

Customizing the Shortcut Key Combinations :

You can change the default key combinations.

1 Make sure Enable shortcut keys is checked and the action you want to change is enabled.

2 Select an Action and click Edit. The Edit Shortcut Key dialog appears.

3 Make sure there is a checkmark in the keys you want to use. You must turn on at least two 
keys.

4 Type the desired letter or number in the field. For example, the following creates the shortcut 
combination Shift-Alt-U.

The following rules apply :

• You cannot override standard Microsoft Windows combinations such as Control-Alt-
Delete.

• The shortcut applies when Ubity UC Desktop is running, regardless of the application that 
is in focus. For example, if Ubity UC Desktop is running but another application has focus, 
pressing Control-Alt-Shift-A will answer an incoming call.

• If another application has the same shortcut combination, then which application was 
started later has control over that combination.

• If the shortcut is not valid at a particular moment, then it has no effect. For example, 
pressing Control-Alt- Shift-A has no effect if there is no incoming call in Ubity UC Desktop.
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   PREFERENCES – CALLS

Field Description

Answer Calls These settings let you configure how you want 
auto answer to handle incoming calls, when Auto 
Answer is enabled. (To enable Auto Answer, see 
page 15)

DTMF You may need to change the DTMF configuration 
if you cannot interact with interactive voice 
response systems (auto attendants, voice-
activated menus, and so on).

Contact Ubity’s technical support or system 
administrator for the correct setting.



59CONFIGURING PREFERENCES

Field Description

RTP This timer controls how calls are disconnected 
when Ubity UC Desktop determines that there is 
a problem with the call and the other party has 
probably disappeared (assuming that you have 
not yourself detected the problem and hung up 
manually).

Typically, the timer is enabled. It is recommended 
that you not disable it. You can change the length 
of the timer, but do not set it to less than 30 
seconds.

Preserve bandwidth When this feature is on, Ubity UC Desktop stops 
sending audio when you are not talking.

When this feature is off, Ubity UC Desktop always 
sends audio, which uses more bandwidth but 
may result in better call quality.

Typically off. However, if you are using a slow 
(dial-up or ISDN) connection, you may want to 
turn it on.
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   PREFERENCES – FILES & WEB TABS

Field Description

Recording folder The folder where files for recording of phone calls 
will be saved.

Transfer folder The folder where received files will be saved.
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8 — APPLICATION HOT KEYS

Function Keyboard Shortcut

Making or answering a call

Answer an incoming call Control + N

Decline an incoming call Control + D

Redial the last dialed number Control + R
or Control + R then 
Enter

End the call
End the conference call (hang up on all participants)

Control + E

During a call

Mute your voice during a call Control + M

Hold or resume the call when the focus is on the Call panel Control + H

Transfer an established call when the focus is on the Call panel Control + T

Turn volume up when the focus is on the Call panel Up key

Turn volume down when the focus is on the Call panel Down key

Display in full screen when the focus is on the Video window F11

Opening a window

Open the Messages window Shift + Ctrl + M

Open the Preferences window F8

Open Troubleshooting Diagnostics Ctrl + F9

Open Help in a browser F1

Exiting

Quit Ubity UC Desktop Ctrl + Q

If some hot keys seem to not be working, you may have to Enable shortcut keys by checking the 
box under Preferences > Shortcut keys.


